1234567891011121314151617181920212223242526272829303132333435363738 |
- Description: Support the new /run/udev location for udev detection.
- /run is a new cross-distribution location for the storage of
- transient state files, i.e. files containing run-time information
- that may or may not need to be written early in the boot process and
- which does not require preserving across reboots.
- A result of that change is that udev no longer uses /dev/ to store
- its runtime state file, i.e. the /dev/.udev/ directory, /dev/.udevdb
- and /dev/.udev.tdb are gone and udev uses /run/udev/ now.
- Author: Roger Leigh <rleigh@codelibre.net>
- Origin: other, http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=10;filename=aoetools-run-udev.patch;att=1;bug=644308
- Bug-Debian: http://bugs.debian.org/644308
- Forwarded: no
- Reviewed-By: David Martínez Moreno <ender@debian.org>
- Last-Update: 2014-01-13
- --- aoetools-36.orig/aoe-mkdevs
- +++ aoetools-36/aoe-mkdevs
- @@ -23,7 +23,7 @@ $zero: Exiting.
- EOF
- exit 1
- fi
- -if test "`ps axwwww | grep 'udev[d]'`" || test -d "/dev/.udev"; then
- +if test "`ps axwwww | grep 'udev[d]'`" || test -d "/run/udev" || test -d "/dev/.udev"; then
- cat 1>&2 <<EOF
- $zero Error: udev detected. You shouldn't need to use $zero.
- $zero: Please see the aoe-mkdevs manpage.
- --- aoetools-36.orig/aoe-mkshelf.in
- +++ aoetools-36/aoe-mkshelf.in
- @@ -18,7 +18,7 @@ $zero: Exiting.
- EOF
- exit 1
- fi
- -if test "`ps axwwww | grep 'udev[d]'`" || test -d "/dev/.udev"; then
- +if test "`ps axwwww | grep 'udev[d]'`" || test -d "/run/udev" || test -d "/dev/.udev"; then
- cat 1>&2 <<EOF
- $zero Error: udev detected. You shouldn't need to use $zero.
- $zero: Please see the aoe-mkshelf manpage.
|