02_no_hyphen_in_manpages.patch 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. # 02_no_hyphen_in_manpages.patch
  2. #
  3. # Patched all the manpages in order to avoid usual hyphen->minus confusion.
  4. #
  5. Index: aoetools-30/aoecfg.8
  6. ===================================================================
  7. --- aoetools-30.orig/aoecfg.8
  8. +++ aoetools-30/aoecfg.8
  9. @@ -3,7 +3,7 @@
  10. aoecfg \- manipulate AoE configuration strings
  11. .SH SYNOPSIS
  12. .B aoecfg
  13. -[-c \fIcmd\fR] [-s \fIcfgstr\fR] [-t \fItimeout\fR] [\fIshelf slot\fR] [\fInetif\fR]
  14. +[\-c \fIcmd\fR] [\-s \fIcfgstr\fR] [\-t \fItimeout\fR] [\fIshelf slot\fR] [\fInetif\fR]
  15. .fi
  16. .SH DESCRIPTION
  17. .IR Aoecfg (8)
  18. Index: aoetools-30/aoe-mkdevs.8
  19. ===================================================================
  20. --- aoetools-30.orig/aoe-mkdevs.8
  21. +++ aoetools-30/aoe-mkdevs.8
  22. @@ -52,13 +52,13 @@ sysadmin gets rid of the mismatching dev
  23. .IP
  24. .EX
  25. .nf
  26. -nai:~# rm -rf /dev/etherd
  27. +nai:~# rm \-rf /dev/etherd
  28. nai:~# aoe-mkdevs /dev/etherd
  29. -nai:~# ls /dev/etherd | wc -l
  30. +nai:~# ls /dev/etherd | wc \-l
  31. 1603
  32. -nai:~# rm -rf /dev/etherd
  33. +nai:~# rm \-rf /dev/etherd
  34. nai:~# n_partitions=1 aoe-mkdevs /dev/etherd
  35. -nai:~# ls /dev/etherd | wc -l
  36. +nai:~# ls /dev/etherd | wc \-l
  37. 103
  38. .fi
  39. .EE
  40. Index: aoetools-30/aoe-mkshelf.8
  41. ===================================================================
  42. --- aoetools-30.orig/aoe-mkshelf.8
  43. +++ aoetools-30/aoe-mkshelf.8
  44. @@ -52,11 +52,11 @@ command is called again with \fIn_partit
  45. .EX
  46. .nf
  47. nai:~# aoe-mkshelf /dev/etherd 7
  48. -nai:~# ls /dev/etherd/e7.* | wc -l
  49. +nai:~# ls /dev/etherd/e7.* | wc \-l
  50. 160
  51. nai:~# rm /dev/etherd/e7.*
  52. nai:~# n_partitions=1 aoe-mkshelf /dev/etherd 7
  53. -nai:~# ls /dev/etherd/e7.* | wc -l
  54. +nai:~# ls /dev/etherd/e7.* | wc \-l
  55. 10
  56. nai:~#
  57. .fi
  58. Index: aoetools-30/aoeping.8
  59. ===================================================================
  60. --- aoetools-30.orig/aoeping.8
  61. +++ aoetools-30/aoeping.8
  62. @@ -69,7 +69,7 @@ requires data
  63. transfer, one sector (512 bytes) of data is always the amount
  64. transfered. If the command takes a parameter (for the Low LBA
  65. register), then the name of the SMART command is immediately followed
  66. -by a colon and then a number, the value of the parameter, e.g., "-S
  67. +by a colon and then a number, the value of the parameter, e.g., "\-S
  68. read_log:1".
  69. .IP
  70. read_data
  71. @@ -119,7 +119,7 @@ network interface eth0.
  72. .IP
  73. .EX
  74. .nf
  75. -bash# aoeping -v 10 9 eth0 | head
  76. +bash# aoeping \-v 10 9 eth0 | head
  77. tag: 80000000
  78. eth: eth0
  79. shelf: 10
  80. @@ -139,7 +139,7 @@ timeout.
  81. .IP
  82. .EX
  83. .nf
  84. -bash# aoeping -i -s 20 \\
  85. +bash# aoeping \-i \-s 20 \\
  86. 10 9 eth0 > /dev/null \\
  87. && echo ok
  88. ok
  89. @@ -154,7 +154,7 @@ threshold.
  90. .IP
  91. .EX
  92. .nf
  93. -bash# aoeping -S return_status \\
  94. +bash# aoeping \-S return_status \\
  95. 10 9 eth0 | grep 'LBA Mid: 0x4f' \\
  96. > /dev/null \\
  97. && echo ok