aoetools.postinst 468 B

123456789101112131415161718192021222324
  1. #!/bin/sh
  2. set -e
  3. case "$1" in
  4. configure)
  5. if which udevadm >/dev/null; then
  6. udevadm control --reload || true
  7. fi
  8. # load the kernel module (as opposed to letting the init script do it)
  9. if [ -d /run/systemd/system ] ; then
  10. /lib/systemd/systemd-modules-load aoetools.conf
  11. fi
  12. ;;
  13. abort-upgrade|abort-remove|abort-deconfigure)
  14. ;;
  15. *)
  16. echo "postinst called with unknown argument '$1'"
  17. exit 1
  18. ;;
  19. esac
  20. #DEBHELPER#
  21. exit 0