1484013170.aoetools-36-7-gf2d2325.avoid-hyphen-vs-minus-issues.patch 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596
  1. Subject: Avoid hyphen vs minus issues
  2. Origin: aoetools-36-7-gf2d2325 <https://github.com/OpenAoE/aoetools/commit/aoetools-36-7-gf2d2325>
  3. Upstream-Author: Ed Cashin <ed.cashin@acm.org>
  4. Date: Mon Jan 9 20:52:50 2017 -0500
  5. ender@debian.org submitted these changes to the man pages, so
  6. that dashes would not by transformed into hyphens.
  7. --- a/aoe-mkdevs.8
  8. +++ b/aoe-mkdevs.8
  9. @@ -52,13 +52,13 @@
  10. .IP
  11. .EX
  12. .nf
  13. -nai:~# rm -rf /dev/etherd
  14. +nai:~# rm \-rf /dev/etherd
  15. nai:~# aoe-mkdevs /dev/etherd
  16. -nai:~# ls /dev/etherd | wc -l
  17. +nai:~# ls /dev/etherd | wc \-l
  18. 1603
  19. -nai:~# rm -rf /dev/etherd
  20. +nai:~# rm \-rf /dev/etherd
  21. nai:~# n_partitions=1 aoe-mkdevs /dev/etherd
  22. -nai:~# ls /dev/etherd | wc -l
  23. +nai:~# ls /dev/etherd | wc \-l
  24. 103
  25. .fi
  26. .EE
  27. --- a/aoe-mkshelf.8
  28. +++ b/aoe-mkshelf.8
  29. @@ -52,11 +52,11 @@
  30. .EX
  31. .nf
  32. nai:~# aoe-mkshelf /dev/etherd 7
  33. -nai:~# ls /dev/etherd/e7.* | wc -l
  34. +nai:~# ls /dev/etherd/e7.* | wc \-l
  35. 160
  36. nai:~# rm /dev/etherd/e7.*
  37. nai:~# n_partitions=1 aoe-mkshelf /dev/etherd 7
  38. -nai:~# ls /dev/etherd/e7.* | wc -l
  39. +nai:~# ls /dev/etherd/e7.* | wc \-l
  40. 10
  41. nai:~#
  42. .fi
  43. --- a/aoecfg.8
  44. +++ b/aoecfg.8
  45. @@ -3,7 +3,7 @@
  46. aoecfg \- manipulate AoE configuration strings
  47. .SH SYNOPSIS
  48. .B aoecfg
  49. -[-c \fIcmd\fR] [-s \fIcfgstr\fR] [-t \fItimeout\fR] [\fIshelf slot\fR] [\fInetif\fR]
  50. +[\-c \fIcmd\fR] [\-s \fIcfgstr\fR] [\-t \fItimeout\fR] [\fIshelf slot\fR] [\fInetif\fR]
  51. .fi
  52. .SH DESCRIPTION
  53. .IR Aoecfg (8)
  54. --- a/aoeping.8
  55. +++ b/aoeping.8
  56. @@ -67,9 +67,9 @@
  57. SMART commands in the list below are supported. If the command
  58. requires data
  59. transfer, one sector (512 bytes) of data is always the amount
  60. -transfered. If the command takes a parameter (for the Low LBA
  61. +transferred. If the command takes a parameter (for the Low LBA
  62. register), then the name of the SMART command is immediately followed
  63. -by a colon and then a number, the value of the parameter, e.g., "-S
  64. +by a colon and then a number, the value of the parameter, e.g., "\-S
  65. read_log:1".
  66. .IP
  67. read_data
  68. @@ -119,7 +119,7 @@
  69. .IP
  70. .EX
  71. .nf
  72. -bash# aoeping -v 10 9 eth0 | head
  73. +bash# aoeping \-v 10 9 eth0 | head
  74. tag: 80000000
  75. eth: eth0
  76. shelf: 10
  77. @@ -139,7 +139,7 @@
  78. .IP
  79. .EX
  80. .nf
  81. -bash# aoeping -i -s 20 \\
  82. +bash# aoeping \-i \-s 20 \\
  83. 10 9 eth0 > /dev/null \\
  84. && echo ok
  85. ok
  86. @@ -154,7 +154,7 @@
  87. .IP
  88. .EX
  89. .nf
  90. -bash# aoeping -S return_status \\
  91. +bash# aoeping \-S return_status \\
  92. 10 9 eth0 | grep 'LBA Mid: 0x4f' \\
  93. > /dev/null \\
  94. && echo ok