04_support_slash_run_slash_udev.patch 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. Description: Support the new /run/udev location for udev detection.
  2. /run is a new cross-distribution location for the storage of
  3. transient state files, i.e. files containing run-time information
  4. that may or may not need to be written early in the boot process and
  5. which does not require preserving across reboots.
  6. .
  7. A result of that change is that udev no longer uses /dev/ to store
  8. its runtime state file, i.e. the /dev/.udev/ directory, /dev/.udevdb
  9. and /dev/.udev.tdb are gone and udev uses /run/udev/ now.
  10. Author: Roger Leigh <rleigh@codelibre.net>
  11. Origin: other, https://bugs.debian.org/cgi-bin/bugreport.cgi?msg=10;filename=aoetools-run-udev.patch;att=1;bug=644308
  12. Bug-Debian: https://bugs.debian.org/644308
  13. Forwarded: no
  14. Reviewed-By: David Martínez Moreno <ender@debian.org>
  15. Last-Update: 2014-01-13
  16. --- a/aoe-mkdevs
  17. +++ b/aoe-mkdevs
  18. @@ -23,7 +23,7 @@
  19. EOF
  20. exit 1
  21. fi
  22. -if test "`ps axwwww | grep 'udev[d]'`" || test -d "/dev/.udev"; then
  23. +if test "`ps axwwww | grep 'udev[d]'`" || test -d "/run/udev" || test -d "/dev/.udev"; then
  24. cat 1>&2 <<EOF
  25. $zero Error: udev detected. You shouldn't need to use $zero.
  26. $zero: Please see the aoe-mkdevs manpage.
  27. --- a/aoe-mkshelf.in
  28. +++ b/aoe-mkshelf.in
  29. @@ -18,7 +18,7 @@
  30. EOF
  31. exit 1
  32. fi
  33. -if test "`ps axwwww | grep 'udev[d]'`" || test -d "/dev/.udev"; then
  34. +if test "`ps axwwww | grep 'udev[d]'`" || test -d "/run/udev" || test -d "/dev/.udev"; then
  35. cat 1>&2 <<EOF
  36. $zero Error: udev detected. You shouldn't need to use $zero.
  37. $zero: Please see the aoe-mkshelf manpage.