rules 584 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. # export DH_VERBOSE=1
  4. build: build-stamp
  5. build-stamp:
  6. $(MAKE)
  7. touch build-stamp
  8. binary-arch: build
  9. dh_testdir
  10. dh_testroot
  11. dh_clean -k
  12. dh_installdocs
  13. dh_installchangelogs
  14. $(MAKE) install PREFIX=debian/aoetools SBINDIR=debian/aoetools/sbin
  15. dh_installinit -u"start 41 S ."
  16. dh_strip
  17. dh_compress
  18. dh_fixperms
  19. dh_installdeb
  20. dh_shlibdeps
  21. dh_gencontrol
  22. dh_md5sums
  23. dh_builddeb
  24. binary-indep:
  25. # do nothing
  26. binary: binary-arch binary-indep
  27. clean:
  28. dh_testdir
  29. dh_testroot
  30. $(MAKE) clean
  31. rm -f *-stamp
  32. dh_clean