rules 522 B

12345678910111213141516171819202122232425262728293031323334353637
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. # export DH_VERBOSE=1
  4. build: build-stamp
  5. build-stamp:
  6. $(MAKE)
  7. touch build-stamp
  8. binary-arch: build
  9. dh_testdir
  10. dh_testroot
  11. dh_clean -k
  12. dh_installdocs
  13. dh_installchangelogs
  14. $(MAKE) install PREFIX=debian/aoetools
  15. dh_strip
  16. dh_compress
  17. dh_fixperms
  18. dh_installdeb
  19. dh_shlibdeps
  20. dh_gencontrol
  21. dh_md5sums
  22. dh_builddeb
  23. binary-indep:
  24. # do nothing
  25. binary: binary-arch binary-indep
  26. clean:
  27. dh_testdir
  28. dh_testroot
  29. $(MAKE) clean
  30. rm -f *-stamp
  31. dh_clean