04_support_slash_run_slash_udev.patch 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. Description: Support the new /run/udev location for udev detection.
  2. /run is a new cross-distribution location for the storage of
  3. transient state files, i.e. files containing run-time information
  4. that may or may not need to be written early in the boot process and
  5. which does not require preserving across reboots.
  6. A result of that change is that udev no longer uses /dev/ to store
  7. its runtime state file, i.e. the /dev/.udev/ directory, /dev/.udevdb
  8. and /dev/.udev.tdb are gone and udev uses /run/udev/ now.
  9. Author: Roger Leigh <rleigh@codelibre.net>
  10. Origin: other, http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=10;filename=aoetools-run-udev.patch;att=1;bug=644308
  11. Bug-Debian: http://bugs.debian.org/644308
  12. Forwarded: no
  13. Reviewed-By: David Martínez Moreno <ender@debian.org>
  14. Last-Update: 2014-01-13
  15. --- aoetools-36.orig/aoe-mkdevs
  16. +++ aoetools-36/aoe-mkdevs
  17. @@ -23,7 +23,7 @@ $zero: Exiting.
  18. EOF
  19. exit 1
  20. fi
  21. -if test "`ps axwwww | grep 'udev[d]'`" || test -d "/dev/.udev"; then
  22. +if test "`ps axwwww | grep 'udev[d]'`" || test -d "/run/udev" || test -d "/dev/.udev"; then
  23. cat 1>&2 <<EOF
  24. $zero Error: udev detected. You shouldn't need to use $zero.
  25. $zero: Please see the aoe-mkdevs manpage.
  26. --- aoetools-36.orig/aoe-mkshelf.in
  27. +++ aoetools-36/aoe-mkshelf.in
  28. @@ -18,7 +18,7 @@ $zero: Exiting.
  29. EOF
  30. exit 1
  31. fi
  32. -if test "`ps axwwww | grep 'udev[d]'`" || test -d "/dev/.udev"; then
  33. +if test "`ps axwwww | grep 'udev[d]'`" || test -d "/run/udev" || test -d "/dev/.udev"; then
  34. cat 1>&2 <<EOF
  35. $zero Error: udev detected. You shouldn't need to use $zero.
  36. $zero: Please see the aoe-mkshelf manpage.