aoetools.postinst 536 B

1234567891011121314151617181920212223
  1. #!/bin/sh
  2. set -e
  3. case "$1" in
  4. configure)
  5. if command -v udevadm >/dev/null; then
  6. udevadm control --reload || true
  7. fi
  8. # load the kernel module (as opposed to letting the init script do it)
  9. if [ -d /run/systemd/system ]; then
  10. /lib/systemd/systemd-modules-load aoetools.conf || true
  11. fi
  12. ;;
  13. abort-upgrade | abort-remove | abort-deconfigure) ;;
  14. *)
  15. echo "postinst called with unknown argument '$1'"
  16. exit 1
  17. ;;
  18. esac
  19. #DEBHELPER#
  20. exit 0