rules 444 B

123456789101112131415161718192021
  1. #!/usr/bin/make -f
  2. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  3. %:
  4. dh $@
  5. override_dh_clean:
  6. dh_clean
  7. -rm debian/bgpdump.1
  8. -rm -rf debian/tests/test_out/
  9. override_dh_install:
  10. dh_install
  11. # don't ship the library for the time being, see README.Debian
  12. rm -rf debian/bgpdump/usr/lib/
  13. rm -rf debian/bgpdump/usr/include/
  14. override_dh_installman:
  15. asciidoctor --attribute reproducible --backend=manpage debian/bgpdump.txt
  16. dh_installman