123456789101112131415161718192021222324252627282930313233 |
- Description: Use strlcat provided by libbsd
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Forwarded: No
- Last-Update: 2016-07-21
- --- a/bgpdump_lib.c
- +++ b/bgpdump_lib.c
- @@ -37,6 +37,7 @@
- #include <netinet/in.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
- +#include <bsd/string.h>
-
- #include <zlib.h>
- #include <assert.h>
- @@ -77,7 +78,7 @@
- static struct aspath *asn32_merge_paths(struct aspath *path, struct aspath *newpath);
- static void asn32_expand_16_to_32(char *dst, char *src, int len);
-
- -#if defined(linux)
- +#if 0
- static size_t strlcat(char *dst, const char *src, size_t size);
- #endif
-
- @@ -1689,7 +1690,7 @@
- }
- }
-
- -#if defined(linux)
- +#if 0
- size_t strlcat(char *dst, const char *src, size_t size) {
- if (strlen (dst) + strlen (src) >= size)
- return -1;
|