add-prototype.patch 652 B

123456789101112131415
  1. Description: Add prototype to avoid a compiler warning
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Bug: https://bitbucket.org/ripencc/bgpdump/issues/27/
  4. Last-Update: 2016-07-18
  5. --- a/bgpdump_lib.c
  6. +++ b/bgpdump_lib.c
  7. @@ -42,6 +42,7 @@
  8. #include <assert.h>
  9. void bgpdump_free_attr(attributes_t *attr);
  10. +int process_mrtd_bgp(struct mstream *s, BGPDUMP_ENTRY *entry);
  11. static int process_mrtd_table_dump(struct mstream *s,BGPDUMP_ENTRY *entry);
  12. static int process_mrtd_table_dump_v2(struct mstream *s,BGPDUMP_ENTRY *entry);
  13. static int process_mrtd_table_dump_v2_peer_index_table(struct mstream *s,BGPDUMP_ENTRY *entry);