fix-getopt-usage.patch 526 B

12345678910111213141516171819
  1. Description: Fix command line parser for archs where char is unsigned
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Bug: https://bitbucket.org/ripencc/bgpdump/issues/36/
  4. Last-Update: 2016-07-22
  5. Else the getopt return code check will always fail on archs where
  6. the char type is unsigned (e.g. armhf, powerpc).
  7. --- a/bgpdump.c
  8. +++ b/bgpdump.c
  9. @@ -137,7 +137,7 @@
  10. int main(int argc, char *argv[]) {
  11. - char c;
  12. + int c;
  13. int fd;
  14. bool usage_error = false;
  15. bool use_syslog = true;