123456789101112131415161718192021222324252627282930313233 |
- Description: Use strlcat provided by libbsd
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Forwarded: No
- Last-Update: 2016-07-21
- --- a/bgpdump_lib.c
- +++ b/bgpdump_lib.c
- @@ -37,6 +37,7 @@
- #include <netinet/in.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
- +#include <bsd/string.h>
-
- #include <zlib.h>
- #include <assert.h>
- @@ -78,7 +79,7 @@
-
- BGPDUMP_TABLE_DUMP_V2_PEER_INDEX_TABLE *table_dump_v2_peer_index_table = NULL;
-
- -#if defined(linux)
- +#if 0
- static size_t strlcat(char *dst, const char *src, size_t size);
- #endif
-
- @@ -1482,7 +1483,7 @@
- }
- }
-
- -#if defined(linux)
- +#if 0
- size_t strlcat(char *dst, const char *src, size_t size) {
- if (strlen (dst) + strlen (src) >= size)
- return -1;
|