12345678910111213141516171819202122232425262728 |
- #!/usr/bin/make -f
- export DEB_BUILD_MAINT_OPTIONS = hardening=+all
- %:
- dh $@
- override_dh_clean:
- dh_clean
- -rm debian/bgpdump.1
- -rm -rf debian/extra-tests/test_out/
- override_dh_auto_test:
- ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- dh_auto_test
- ./test.sh debian/extra-tests/
- @[ -d test_data ] && ./test.sh || echo "Skipping upstream tests as they are huge (see README.Debian)"
- endif
- override_dh_install:
- dh_install
- # don't ship the library for the time being, see README.Debian
- rm -rf debian/bgpdump/usr/lib/
- rm -rf debian/bgpdump/usr/include/
- override_dh_installman:
- scdoc <debian/bgpdump.scd >debian/bgpdump.1
- dh_installman
|