12345678910111213141516 |
- Description: Pass LDFLAGS to bgpdump linkage
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Bug: https://bitbucket.org/ripencc/bgpdump/issues/50
- Last-Update: 2019-01-27
- --- a/Makefile.in
- +++ b/Makefile.in
- @@ -32,7 +32,7 @@
- $(COMPILE) -o example example.c libbgpdump.a $(SYS_LIBS)
-
- bgpdump: bgpdump.c libbgpdump.a
- - $(COMPILE) -o bgpdump bgpdump.c libbgpdump.a $(SYS_LIBS)
- + $(COMPILE) -Wl,-z,relro -Wl,-z,now -o bgpdump bgpdump.c libbgpdump.a $(SYS_LIBS)
-
- check-clean:
- rm -f test_out/*.bgp.gz
|