rules 675 B

12345678910111213141516171819202122232425262728
  1. #!/usr/bin/make -f
  2. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  3. %:
  4. dh $@
  5. override_dh_clean:
  6. dh_clean
  7. -rm debian/bgpdump.1
  8. -rm -rf debian/extra-tests/test_out/
  9. override_dh_auto_test:
  10. ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
  11. dh_auto_test
  12. ./test.sh debian/extra-tests/
  13. @[ -d test_data ] && ./test.sh || echo "Skipping upstream tests as they are huge (see README.Debian)"
  14. endif
  15. override_dh_install:
  16. dh_install
  17. # don't ship the library for the time being, see README.Debian
  18. rm -rf debian/bgpdump/usr/lib/
  19. rm -rf debian/bgpdump/usr/include/
  20. override_dh_installman:
  21. asciidoctor --attribute reproducible --backend=manpage debian/bgpdump.txt
  22. dh_installman