1234567891011121314151617181920212223242526272829303132333435363738 |
- Description: Disable the cfr_strerror function
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Bug: https://bitbucket.org/ripencc/bgpdump/issues/31/
- Last-Update: 2016-07-19
- This function does not check the asprintf return value but it's not
- used anyany. So disable it.
- --- a/cfile_tools.c
- +++ b/cfile_tools.c
- @@ -443,6 +443,7 @@
- }
-
-
- +#if 0
- char * cfr_strerror(CFRFILE *stream) {
- // Result is "stream-i/o: <stream-error> <compressor>[: <compressor error>]"
- // Do not modify result.
- @@ -482,6 +483,7 @@
- free(msg);
- return(res);
- }
- +#endif
-
- const char * cfr_compressor_str(CFRFILE *stream) {
- // Returns the name of the compressor used
- --- a/cfile_tools.h
- +++ b/cfile_tools.h
- @@ -80,7 +80,9 @@
- ssize_t cfr_getline(char **lineptr, size_t *n, CFRFILE *stream);
- int cfr_eof(CFRFILE *stream);
- int cfr_error(CFRFILE *stream);
- +#if 0
- char * cfr_strerror(CFRFILE *stream);
- +#endif
- const char * cfr_compressor_str(CFRFILE *stream);
-
- #ifndef DONT_HAVE_BZ2
|