12345678910111213141516171819 |
- Description: Fix command line parser for archs where char is unsigned
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Bug: https://bitbucket.org/ripencc/bgpdump/issues/36/
- Last-Update: 2016-07-22
- Else the getopt return code check will always fail on archs where
- the char type is unsigned (e.g. armhf, powerpc).
- --- a/bgpdump.c
- +++ b/bgpdump.c
- @@ -137,7 +137,7 @@
-
- int main(int argc, char *argv[]) {
-
- - char c;
- + int c;
- int fd;
- bool usage_error = false;
- bool use_syslog = true;
|