debian.hardening.patch 512 B

12345678910111213141516
  1. Description: Pass LDFLAGS to bgpdump linkage
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Bug: https://bitbucket.org/ripencc/bgpdump/issues/50
  4. Last-Update: 2019-01-27
  5. --- a/Makefile.in
  6. +++ b/Makefile.in
  7. @@ -32,7 +32,7 @@
  8. $(COMPILE) -o example example.c libbgpdump.a $(SYS_LIBS)
  9. bgpdump: bgpdump.c libbgpdump.a
  10. - $(COMPILE) -o bgpdump bgpdump.c libbgpdump.a $(SYS_LIBS)
  11. + $(COMPILE) -Wl,-z,relro -Wl,-z,now -o bgpdump bgpdump.c libbgpdump.a $(SYS_LIBS)
  12. check-clean:
  13. rm -f test_out/*.bgp.gz