fix-test.patch 513 B

12345678910111213141516
  1. Description: Fix the test run, Debian has zcat, not gzcat
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Bug: https://bitbucket.org/ripencc/bgpdump/issues/34/
  4. Last-Update: 2016-07-18
  5. --- a/test.sh
  6. +++ b/test.sh
  7. @@ -9,7 +9,7 @@
  8. echo -n " testing $mrt..."
  9. OUT=$mrt.bgp.gz
  10. ./bgpdump -vm test_data/$mrt > test_out/$OUT
  11. - gzcat test_expect/$OUT | diff -q test_out/$OUT -
  12. + zcat test_expect/$OUT | diff -q test_out/$OUT -
  13. if [ $? == 0 ]; then
  14. echo "success"
  15. else