upstream.work-around-missing-dev-fd-links.patch 1.1 KB

123456789101112131415161718192021222324252627282930313233343536
  1. Subject: Work around /dev/fd/<num> no longer being created by systemd
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2020-05-21
  4. Bug: https://github.com/latchset/clevis/issues/262
  5. Bug-Debian: https://bugs.debian.org/968518
  6. --- a/src/clevis-decrypt
  7. +++ b/src/clevis-decrypt
  8. @@ -46,7 +46,8 @@
  9. exit 1
  10. fi
  11. - exec "$cmd" < <(echo -n "$hdr."; /bin/cat)
  12. + (echo -n "$hdr."; /bin/cat) | "$cmd"
  13. + exit $?
  14. fi
  15. exec >&2
  16. --- a/src/pins/tang/clevis-decrypt-tang
  17. +++ b/src/pins/tang/clevis-decrypt-tang
  18. @@ -88,4 +88,5 @@
  19. tmp="$(jose jwk exc -i '{"alg":"ECMR"}' -l- -r- <<< "$eph$srv")"
  20. rep="$(jose jwk pub -i- <<< "$rep")"
  21. jwk="$(jose jwk exc -l- -r- <<< "$rep$tmp")"
  22. -exec jose jwe dec -k- -i- < <(echo -n "$jwk$hdr."; /bin/cat)
  23. +(echo -n "$jwk$hdr."; /bin/cat) | jose jwe dec -k- -i-
  24. +exit $?
  25. --- a/src/pins/tpm2/clevis-decrypt-tpm2
  26. +++ b/src/pins/tpm2/clevis-decrypt-tpm2
  27. @@ -169,4 +169,5 @@
  28. # directory at this point.
  29. [ -d "${TMP}" ] && rm -rf "${TMP}"
  30. -exec jose jwe dec -k- -i- < <(echo -n "$jwk$hdr."; /bin/cat)
  31. +(echo -n "$jwk$hdr."; /bin/cat) | jose jwe dec -k- -i-
  32. +exit $?