clevis-udisks2.postinst 364 B

1234567891011121314151617181920
  1. #!/bin/sh
  2. set -e
  3. case "$1" in
  4. configure)
  5. if ! getent passwd _clevis >/dev/null; then
  6. adduser --quiet --system --group --no-create-home --home /nonexistent --force-badname _clevis
  7. fi
  8. ;;
  9. abort-upgrade|abort-remove|abort-deconfigure)
  10. ;;
  11. *)
  12. echo "postinst called with unknown argument '$1'" >&2
  13. exit 1
  14. ;;
  15. esac
  16. #DEBHELPER#
  17. exit 0