123456789101112131415 |
- #!/bin/sh
- set -e
- cd src/luks/tests
- # patch out lukv2 detection switch - we're on the bright side already
- sed -e 's/@OLD_CRYPTSETUP@/0/' \
- <tests-common-functions.in >tests-common-functions
- for f in $(find . -type f -not -name 'tests-common-functions*' -executable | sort) ; do
- echo "I: Running test $f"
- # test are very noisy, keep them silent as long as they pass
- chronic "$f" || :
- done
|