2018-10-30.use-asciidoctor-to-build-manpages.patch 993 B

1234567891011121314151617181920212223242526272829
  1. Subject: Use asciidoctor to build the manpages
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2018-10-30
  4. Bug: https://github.com/latchset/tang/issues/32
  5. --- a/meson.build
  6. +++ b/meson.build
  7. @@ -41,7 +41,7 @@
  8. jansson = dependency('jansson', version: '>=2.10', required: false)
  9. jose = dependency('jose', version: '>=8')
  10. -a2x = find_program('a2x', required: false)
  11. +asciidoctor = find_program('asciidoctor', required: false)
  12. bins = []
  13. mans = []
  14. @@ -50,10 +50,10 @@
  15. install_data(bins, install_dir: bindir)
  16. -if a2x.found()
  17. +if asciidoctor.found()
  18. foreach m : mans
  19. custom_target(m.split('/')[-1], input: m + '.adoc', output: m.split('/')[-1],
  20. - command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  21. + command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  22. install_dir: join_paths(get_option('mandir'), 'man' + m.split('.')[-1]),
  23. install: true
  24. )