run-testsuite 407 B

123456789101112131415
  1. #!/bin/sh
  2. set -e
  3. cd src/luks/tests
  4. # patch out lukv2 detection switch - we're on the bright side already
  5. sed -e 's/@OLD_CRYPTSETUP@/0/' \
  6. <tests-common-functions.in >tests-common-functions
  7. for f in $(find . -type f -not -name 'tests-common-functions*' -executable | sort) ; do
  8. echo "I: Running test $f"
  9. # test are very noisy, keep them silent as long as they pass
  10. chronic "$f" || :
  11. done