1541598788.v11-1-g1e344db.delete-remaining-references-to-the-removed-http-pin.patch 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. Subject: Delete remaining references to the removed http pin
  2. Origin: v11-1-g1e344db <https://github.com/latchset/clevis/commit/v11-1-g1e344db>
  3. Upstream-Author: Javier Martinez Canillas <javierm@redhat.com>
  4. Date: Wed Nov 7 14:53:08 2018 +0100
  5. Bug-Debian: https://bugs.debian.org/bug=969361
  6. Commit 800d73185d7f ("Remove HTTP pin") removed the clevis http pin, but
  7. there are still references of it in the docs and also the dracut module.
  8. This was causing dracut to fail building the initramfs due the following:
  9. dracut-install: ERROR: installing 'clevis-decrypt-http'
  10. Suggested-by: Dominick Grift <dac.override@gmail.com>
  11. Fixes: #73
  12. --- a/README.md
  13. +++ b/README.md
  14. @@ -58,27 +58,6 @@
  15. the advertisment is specified manually like this, Clevis presumes that the
  16. advertisement is trusted.
  17. -#### PIN: HTTP
  18. -
  19. -Clevis also ships a pin for performing escrow using HTTP. Please note that,
  20. -at this time, this pin does not provide HTTPS support and is suitable only
  21. -for use over local sockets. This provides integration with services like
  22. -[Custodia](http://github.com/latchset/custodia).
  23. -
  24. -For example:
  25. -
  26. -```bash
  27. -$ echo hi | clevis encrypt http '{"url": "http://server.local/key"}' > hi.jwe
  28. -```
  29. -
  30. -The HTTP pin generate a new (cryptographically-strong random) key and performs
  31. -encryption using it. It then performs a PUT request to the URL specified. It is
  32. -understood that the server will securely store this key for later retrieval.
  33. -During decryption, the pin will perform a GET request to retrieve the key and
  34. -perform decryption.
  35. -
  36. -Patches to provide support for HTTPS and authentication are welcome.
  37. -
  38. #### PIN: TPM2
  39. Clevis provides support to encrypt a key in a Trusted Platform Module 2.0 (TPM2)
  40. --- a/src/clevis.1.adoc
  41. +++ b/src/clevis.1.adoc
  42. @@ -21,26 +21,6 @@
  43. encrypt the data so that it can be automatically decrypted if the policy is
  44. met. Lets walk through an example.
  45. -== HTTP ESCROW
  46. -
  47. -When using the HTTP pin, we create a new, cryptographically-strong, random key.
  48. -This key is stored in a remote HTTP escrow server (using a simple PUT or POST).
  49. -Then at decryption time, we attempt to fetch the key back again in order to
  50. -decrypt our data. So, for our configuration we need to pass the URL to the key
  51. -location:
  52. -
  53. - $ clevis encrypt http '{"url":"https://escrow.srv/1234"}' < PT > JWE
  54. -
  55. -To decrypt the data, simply provide the ciphertext (JWE):
  56. -
  57. - $ clevis decrypt < JWE > PLAINTEXT
  58. -
  59. -Notice that we did not pass any configuration during decryption. The decrypt
  60. -command extracted the URL (and possibly other configuration) from the JWE
  61. -object, fetched the encryption key from the escrow and performed decryption.
  62. -
  63. -For more information, see link:clevis-encrypt-http.1.adoc[*clevis-encrypt-http*(1)].
  64. -
  65. == TANG BINDING
  66. Clevis provides support for the Tang network binding server. Tang provides
  67. @@ -136,7 +116,6 @@
  68. == SEE ALSO
  69. -link:clevis-encrypt-http.1.adoc[*clevis-encrypt-http*(1)],
  70. link:clevis-encrypt-tang.1.adoc[*clevis-encrypt-tang*(1)],
  71. link:clevis-encrypt-tpm2.1.adoc[*clevis-encrypt-tpm2*(1)],
  72. link:clevis-encrypt-sss.1.adoc[*clevis-encrypt-sss*(1)],
  73. --- a/src/luks/clevis-luks-bind.1.adoc
  74. +++ b/src/luks/clevis-luks-bind.1.adoc
  75. @@ -61,7 +61,6 @@
  76. == SEE ALSO
  77. link:clevis-luks-unlockers.7.adoc[*clevis-luks-unlockers*(7)],
  78. -link:clevis-encrypt-http.1.adoc[*clevis-encrypt-http*(1)],
  79. link:clevis-encrypt-tang.1.adoc[*clevis-encrypt-tang*(1)],
  80. link:clevis-encrypt-sss.1.adoc[*clevis-encrypt-sss*(1)],
  81. link:clevis-decrypt.1.adoc[*clevis-decrypt*(1)]
  82. --- a/src/luks/systemd/dracut/module-setup.sh.in
  83. +++ b/src/luks/systemd/dracut/module-setup.sh.in
  84. @@ -36,7 +36,6 @@
  85. inst_hook initqueue/settled 60 "$moddir/clevis-hook.sh"
  86. inst_multiple /etc/services \
  87. - clevis-decrypt-http \
  88. clevis-decrypt-tang \
  89. clevis-decrypt-sss \
  90. @libexecdir@/clevis-luks-askpass \
  91. --- a/src/pins/sss/clevis-encrypt-sss.1.adoc
  92. +++ b/src/pins/sss/clevis-encrypt-sss.1.adoc
  93. @@ -54,6 +54,5 @@
  94. == SEE ALSO
  95. -link:clevis-encrypt-http.1.adoc[*clevis-encrypt-http*(1)],
  96. link:clevis-encrypt-tang.1.adoc[*clevis-encrypt-tang*(1)],
  97. link:clevis-decrypt.1.adoc[*clevis-decrypt*(1)]