1541599937.v11-2-g3465859.install-cryptsetup-and-tpm2-pcrlist-in-the-initramfs.patch 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. Subject: Install cryptsetup and tpm2_pcrlist in the initramfs
  2. Origin: v11-2-g3465859 <https://github.com/latchset/clevis/commit/v11-2-g3465859>
  3. Upstream-Author: Javier Martinez Canillas <javierm@redhat.com>
  4. Date: Wed Nov 7 15:12:17 2018 +0100
  5. Bug-Debian: https://bugs.debian.org/bug=969361
  6. The cryptsetup and tpm2_pcrlist are missing in the initramfs, this makes
  7. automatic LUKS unlocking fail with the following errors:
  8. dracut-initqueue[382]: /usr/libexec/clevis-luks-askpass: line 52: cryptsetup: command not found
  9. dracut-initqueue[382]: /usr/bin/clevis-decrypt-tpm2: line 40: tpm2_pcrlist: command not found
  10. Suggested-by: Federico Chiacchiaretta <federico.chia@gmail.com>
  11. Fixes: #74
  12. --- a/src/luks/systemd/dracut/module-setup.sh.in
  13. +++ b/src/luks/systemd/dracut/module-setup.sh.in
  14. @@ -40,6 +40,7 @@
  15. clevis-decrypt-sss \
  16. @libexecdir@/clevis-luks-askpass \
  17. clevis-decrypt \
  18. + cryptsetup \
  19. luksmeta \
  20. clevis \
  21. mktemp \
  22. @@ -49,6 +50,7 @@
  23. for cmd in clevis-decrypt-tpm2 \
  24. tpm2_createprimary \
  25. + tpm2_pcrlist \
  26. tpm2_unseal \
  27. tpm2_load; do
  28. @@ -60,6 +62,7 @@
  29. if (($ret == 0)); then
  30. inst_multiple clevis-decrypt-tpm2 \
  31. tpm2_createprimary \
  32. + tpm2_pcrlist \
  33. tpm2_unseal \
  34. tpm2_load
  35. fi