1613255571.v16-2-g0abdfbc.fix-issue-with-multiple-encrypted-devices.patch 738 B

12345678910111213141516171819
  1. Subject: Fix issue with multiple encrypted devices
  2. Origin: v16-2-g0abdfbc <https://github.com/latchset/clevis/commit/v16-2-g0abdfbc>
  3. Upstream-Author: Dmitriy P <dpantel@users.noreply.github.com>
  4. Date: Sat Feb 13 15:32:51 2021 -0700
  5. There is a separate askpass process (with its own PID) for each
  6. encrypted device. So re-get the askpass PID with each loop iteration.
  7. --- a/src/initramfs-tools/scripts/local-top/clevis.in
  8. +++ b/src/initramfs-tools/scripts/local-top/clevis.in
  9. @@ -130,6 +130,8 @@
  10. while true; do
  11. + # Re-get the askpass PID in case there are multiple encrypted devices
  12. + pid=""
  13. until [ "$pid" ] && [ -p "$PASSFIFO" ]; do
  14. sleep .1
  15. pid_fifo=$(get_askpass_pid)