cherry-pick.FILE5_33-2-g35c46552.fix-cast.patch 474 B

12345678910111213141516
  1. Subject: Fix cast
  2. Origin: FILE5_33-2-g35c46552
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Sun Apr 15 19:57:59 2018 +0000
  5. --- a/src/apprentice.c
  6. +++ b/src/apprentice.c
  7. @@ -3335,7 +3335,7 @@
  8. bs1(struct magic *m)
  9. {
  10. m->cont_level = swap2(m->cont_level);
  11. - m->offset = swap4((int32_t)m->offset);
  12. + m->offset = swap4((uint32_t)m->offset);
  13. m->in_offset = swap4((uint32_t)m->in_offset);
  14. m->lineno = swap4((uint32_t)m->lineno);
  15. if (IS_STRING(m->type)) {