12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364 |
- Author: Russell Coker <russell@coker.com.au>
- Description: Adding volume label and UUID support for linux ext (Closes: #489865).
- diff -Naurp file.orig/magic/Magdir/filesystems file/magic/Magdir/filesystems
- --- file.orig/magic/Magdir/filesystems 2008-07-02 13:47:23.000000000 +0000
- +++ file/magic/Magdir/filesystems 2008-07-15 14:21:39.000000000 +0000
- @@ -1027,6 +1027,8 @@
-
- # ext2/ext3 filesystems - Andreas Dilger <adilger@dilger.ca>
- # ext4 filesystem - Eric Sandeen <sandeen@sandeen.net>
- +# volume label and UUID Russell Coker
- +# http://etbe.coker.com.au/2008/07/08/label-vs-uuid-vs-device/
- 0x438 leshort 0xEF53 Linux
- >0x44c lelong x rev %d
- >0x43e leshort x \b.%d
- @@ -1042,25 +1044,32 @@
- # else large RO_COMPAT?
- >>>0x464 lelong >0x0000007 ext4 filesystem data
- # else large INCOMPAT?
- ->>0x460 lelong >0x000003f ext4 filesystem data
- +>>0x460 lelong >0x000003f ext4 filesystem data
- +>0x468 belong x \b, UUID=%08x
- +>0x46c beshort x \b-%04x
- +>0x46e beshort x \b-%04x
- +>0x470 beshort x \b-%04x
- +>0x472 belong x \b-%08x
- +>0x476 beshort x \b%04x
- +>0x478 string >0 \b, volume name "%s"
- # General flags for any ext* fs
- ->0x460 lelong &0x0000004 (needs journal recovery)
- ->0x43a leshort &0x0000002 (errors)
- +>0x460 lelong &0x0000004 (needs journal recovery)
- +>0x43a leshort &0x0000002 (errors)
- # INCOMPAT flags
- ->0x460 lelong &0x0000001 (compressed)
- -#>0x460 lelong &0x0000002 (filetype)
- -#>0x460 lelong &0x0000010 (meta bg)
- ->0x460 lelong &0x0000040 (extents)
- ->0x460 lelong &0x0000080 (64bit)
- -#>0x460 lelong &0x0000100 (mmp)
- -#>0x460 lelong &0x0000200 (flex bg)
- +>0x460 lelong &0x0000001 (compressed)
- +#>0x460 lelong &0x0000002 (filetype)
- +#>0x460 lelong &0x0000010 (meta bg)
- +>0x460 lelong &0x0000040 (extents)
- +>0x460 lelong &0x0000080 (64bit)
- +#>0x460 lelong &0x0000100 (mmp)
- +#>0x460 lelong &0x0000200 (flex bg)
- # RO_INCOMPAT flags
- -#>0x464 lelong &0x0000001 (sparse super)
- ->0x464 lelong &0x0000002 (large files)
- ->0x464 lelong &0x0000008 (huge files)
- -#>0x464 lelong &0x0000010 (gdt checksum)
- -#>0x464 lelong &0x0000020 (many subdirs)
- -#>0x463 lelong &0x0000040 (extra isize)
- +#>0x464 lelong &0x0000001 (sparse super)
- +>0x464 lelong &0x0000002 (large files)
- +>0x464 lelong &0x0000008 (huge files)
- +#>0x464 lelong &0x0000010 (gdt checksum)
- +#>0x464 lelong &0x0000020 (many subdirs)
- +#>0x463 lelong &0x0000040 (extra isize)
-
- # SGI disk labels - Nathan Scott <nathans@debian.org>
- 0 belong 0x0BE5A941 SGI disk label (volume header)
|