upstream.detect-smali.patch 527 B

12345678910111213141516
  1. Subject: Detect smali files
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2022-12-30
  4. Forwarded: https://mailman.astron.com/pipermail/file/2022-December/001049.html
  5. --- a/magic/Magdir/android
  6. +++ b/magic/Magdir/android
  7. @@ -207,3 +207,8 @@
  8. >8 string >000 dex section version: %s,
  9. >12 lelong >0 number of dex files: %d,
  10. >16 lelong >0 verifier deps size: %d
  11. +
  12. +# Disassembled DEX files
  13. +0 string/t .class\x20
  14. +>&0 regex/512 \^\\.super\x20L.*;$ disassembled Android DEX Java class (smali/baksmali)
  15. +!:ext smali