upstream.mute-debug-warning.patch 781 B

12345678910111213141516171819202122232425
  1. Subject: Disable debug messages
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2022-12-20
  4. Forwarded: https://mailman.astron.com/pipermail/file/2022-December/001018.html
  5. --- a/src/softmagic.c
  6. +++ b/src/softmagic.c
  7. @@ -1461,7 +1461,7 @@
  8. // On purpose not INTMAX_MAX
  9. if (lhs >= UINT_MAX || lhs <= INT_MIN ||
  10. off >= UINT_MAX || off <= INT_MIN) {
  11. - fprintf(stderr, "lhs/off overflow %jd %jd\n", lhs, off);
  12. +/* fprintf(stderr, "lhs/off overflow %jd %jd\n", lhs, off); */
  13. return 1;
  14. }
  15. @@ -1497,7 +1497,7 @@
  16. if (m->in_op & FILE_OPINVERSE)
  17. offset = ~offset;
  18. if (offset >= UINT_MAX) {
  19. - fprintf(stderr, "offset overflow %jd\n", offset);
  20. +/* fprintf(stderr, "offset overflow %jd\n", offset); */
  21. return 1;
  22. }
  23. *rv = CAST(uint32_t, offset);