105-magic-remove-emf.dpatch 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 15-magic-remove-emf.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: Disabled EMF detection as it not only caused false positives, which might
  5. ## DP: have been acceptible, but a segmentation fault (closes: #333502).
  6. @DPATCH@
  7. diff -Naur file-4.20.orig/magic/Magdir/msdos file-4.20/magic/Magdir/msdos
  8. --- file-4.20.orig/magic/Magdir/msdos 2007-01-19 19:35:20.000000000 +0000
  9. +++ file-4.20/magic/Magdir/msdos 2007-03-27 12:23:14.000000000 +0000
  10. @@ -572,24 +574,25 @@
  11. >4 byte =0x30 Offline database
  12. -# Windows Enhanced Metafile (EMF)
  13. -# See msdn.microsoft.com/archive/en-us/dnargdi/html/msdn_enhmeta.asp
  14. -# for further information. Note that "0 lelong 1" should be true i.e.
  15. -# the first double word in the file should be 1. With the extended
  16. -# syntax available by some file commands you could write:
  17. -# 0 lelong 1
  18. -# &40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  19. -40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  20. ->44 ulelong x version 0x%x.
  21. -# If the description has a length greater than zero, it exists and is
  22. -# found at offset (*64).
  23. ->64 ulelong >0 Description available at offset 0x%x
  24. ->>60 ulelong >0 (length 0x%x)
  25. -# Note it would be better to print out the description, which is found
  26. -# as below. Unfortunately the following only prints out the first couple
  27. -# of characters instead of all the "description length"
  28. -# number of characters -- indicated by the ulelong at offset 60.
  29. ->>(64.l) lestring16 >0 Description: %15.15s
  30. +# This is pure ASCII magic, "EMF " at position 40 (MPi)
  31. +## Windows Enhanced Metafile (EMF)
  32. +## See msdn.microsoft.com/archive/en-us/dnargdi/html/msdn_enhmeta.asp
  33. +## for further information. Note that "0 lelong 1" should be true i.e.
  34. +## the first double word in the file should be 1. With the extended
  35. +## syntax available by some file commands you could write:
  36. +## 0 lelong 1
  37. +## &40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  38. +#40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  39. +#>44 ulelong x version 0x%x.
  40. +## If the description has a length greater than zero, it exists and is
  41. +## found at offset (*64).
  42. +#>64 ulelong >0 Description available at offset 0x%x
  43. +#>>60 ulelong >0 (length 0x%x)
  44. +## Note it would be better to print out the description, which is found
  45. +## as below. Unfortunately the following only prints out the first couple
  46. +## of characters instead of all the "description length"
  47. +## number of characters -- indicated by the ulelong at offset 60.
  48. +#>>(64.l) lestring16 >0 Description: %15.15s
  49. # From: Alex Beregszaszi <alex@fsn.hu>
  50. 0 string COWD VMWare3