cherry-pick.FILE5_35-3-gc7d910ee.more-lint-fixes.patch 464 B

12345678910111213141516
  1. Subject: More lint fixes
  2. Origin: FILE5_35-3-gc7d910ee <https://github.com/file/file/commit/FILE5_35-3-gc7d910ee>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Fri Oct 19 00:33:04 2018 +0000
  5. --- a/src/file.h
  6. +++ b/src/file.h
  7. @@ -369,7 +369,7 @@
  8. #define CCAST(T, b) const_cast<T>(b)
  9. #else
  10. #define CAST(T, b) ((T)(b))
  11. -#define RCAST(T, b) ((T)(void *)(b))
  12. +#define RCAST(T, b) ((T)(uintptr_t)(b))
  13. #define CCAST(T, b) ((T)(uintptr_t)(b))
  14. #endif