12345678910111213141516 |
- Subject: More lint fixes
- Origin: FILE5_35-3-gc7d910ee <https://github.com/file/file/commit/FILE5_35-3-gc7d910ee>
- Upstream-Author: Christos Zoulas <christos@zoulas.com>
- Date: Fri Oct 19 00:33:04 2018 +0000
- --- a/src/file.h
- +++ b/src/file.h
- @@ -369,7 +369,7 @@
- #define CCAST(T, b) const_cast<T>(b)
- #else
- #define CAST(T, b) ((T)(b))
- -#define RCAST(T, b) ((T)(void *)(b))
- +#define RCAST(T, b) ((T)(uintptr_t)(b))
- #define CCAST(T, b) ((T)(uintptr_t)(b))
- #endif
-
|