1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465 |
- #!/usr/bin/make -f
- package=file
- CFLAGS = -O2 -DHOWMANY=0x18000
- ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
- endif
- build:
- dh_testdir
- ./configure --prefix=/usr '--datadir=$${prefix}/share/misc' \
- '--mandir=$${prefix}/share/man' \
- --enable-fsect-man5
- make "CFLAGS=$(CFLAGS)"
- touch build
- clean:
- dh_testdir
- rm -f build changelog.tmp debian/copyright
- if [ -r Makefile ]; then \
- make distclean; \
- fi
- rm -f config.{log,cache,status} Makefile
- find . -name "*~" | xargs rm -f
- rm -rf debian/tmp debian/files* core debian/substvars
- dh_clean
- binary-indep: build
- dh_testroot
- dh_testdir
- # There are no architecture-independent files to be uploaded
- # generated by this package. If there were any they would be
- # made here.
- binary-arch: build
- dh_testroot
- dh_testdir
- rm -rf debian/tmp
- install -d debian/tmp/usr/bin debian/tmp/etc debian/tmp/usr/share/man/man1 debian/tmp/usr/share/man/man5
- make install prefix=`pwd`/debian/tmp/usr \
- INSTALL="/usr/bin/install -p" # DESTDIR=`pwd`/debian/tmp
- install -m644 -p magic.local `pwd`/debian/tmp/etc/magic
- cat debian/copyright-prolog LEGAL.NOTICE > debian/copyright
- dh_installdirs
- dh_installdocs README
- dh_installchangelogs patchlevel.h
- dh_installmanpages
- dh_strip
- dh_compress
- dh_fixperms
- dh_shlibdeps
- dh_gencontrol
- dh_installdeb
- dh_md5sums
- dh_builddeb
- rm -f debian/copyright
- binary: binary-indep binary-arch
- .PHONY: binary binary-arch binary-indep clean checkroot
|