0003-file-usage.patch 812 B

12345678910111213141516
  1. Author: Daniel Baumann <mail@daniel-baumann.ch>
  2. Description: Adding POSIXLY_CORRECT reference in usage message (Closes: #576679).
  3. --- a/src/file_opts.h
  4. +++ b/src/file_opts.h
  5. @@ -34,8 +34,8 @@
  6. OPT('k', "keep-going", 0, " don't stop at the first match\n")
  7. OPT('l', "list", 0, " list magic strength\n")
  8. #ifdef S_IFLNK
  9. -OPT('L', "dereference", 0, " follow symlinks (default)\n")
  10. -OPT('h', "no-dereference", 0, " don't follow symlinks\n")
  11. +OPT('L', "dereference", 0, " follow symlinks (default if POSIXLY_CORRECT is set)\n")
  12. +OPT('h', "no-dereference", 0, " don't follow symlinks (default if POSIXLY_CORRECT is not set)\n")
  13. #endif
  14. OPT('n', "no-buffer", 0, " do not buffer output\n")
  15. OPT('N', "no-pad", 0, " do not pad output\n")