Christos Zoulas 2af85bfcf5 Import upstream version 4.26 13 years ago
..
Makefile.am 927e10538d Import upstream version 4.12 17 years ago
Makefile.in 2af85bfcf5 Import upstream version 4.26 13 years ago
README 927e10538d Import upstream version 4.12 17 years ago
example.py 927e10538d Import upstream version 4.12 17 years ago
py_magic.c 927e10538d Import upstream version 4.12 17 years ago
py_magic.h 927e10538d Import upstream version 4.12 17 years ago
setup.py 927e10538d Import upstream version 4.12 17 years ago

README


This directory contains Python bindings to allow you to access the
libmagic api. At the moment their status is "experimental" and
they are not built by default. You may need to edit include and library
search paths in setup.py so that python's distutils build process can
find the magic header and lib files.

In order to be able to compile magic-python you need to have python
and the python-dev packages installed.

Python libraries are always built for a particular version of Python
(2.2, 2.3, etc), and libraries built for one version will not be seen
by another.

To build:

$ python setup.py build

Now, you can install the modules:

$ cp build/lib.*/magic.so /usr/lib/python2.3/lib-dynload/

(the directory /usr/lib/python2.3 may vary, depending on your installation)

magic-python should work now!