123456789101112131415161718 |
- Subject: %td is for ptrdiff_t not for off_t
- Origin: FILE5_38-1-gd955cefc <https://github.com/file/file/commit/FILE5_38-1-gd955cefc>
- Upstream-Author: Christos Zoulas <christos@zoulas.com>
- Date: Tue Dec 17 15:27:27 2019 +0000
- --- a/src/readelf.c
- +++ b/src/readelf.c
- @@ -1349,8 +1349,8 @@
- name_off = xsh_offset;
-
- if (fsize != SIZE_UNKNOWN && fsize < name_off) {
- - if (file_printf(ms, ", too large section header offset %td",
- - name_off) == -1)
- + if (file_printf(ms, ", too large section header offset %jd",
- + (intmax_t)name_off) == -1)
- return -1;
- return 0;
- }
|