increase.number.use.magic.limit.patch 601 B

1234567891011121314151617
  1. Subject: Change default for name/use to 50
  2. Origin: Part of FILE5_38-65-gdf476c81 <https://github.com/file/file/commit/FILE5_38-65-gdf476c81>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Thu Mar 19 20:41:11 2020 +0000
  5. Bug-Debian: https://bugs.debian.org/928009
  6. --- a/src/file.h
  7. +++ b/src/file.h
  8. @@ -437,7 +437,7 @@
  9. uint16_t regex_max;
  10. size_t bytes_max; /* number of bytes to read from file */
  11. #define FILE_INDIR_MAX 50
  12. -#define FILE_NAME_MAX 30
  13. +#define FILE_NAME_MAX 50
  14. #define FILE_ELF_SHNUM_MAX 32768
  15. #define FILE_ELF_PHNUM_MAX 2048
  16. #define FILE_ELF_NOTES_MAX 256