123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657 |
- #!/usr/bin/make -f
- package=file
- build:
- $(checkdir)
- ./configure --prefix=/usr
- make
- touch build
- clean:
- $(checkdir)
- rm -f build changelog.tmp debian/copyright
- if [ -r Makefile ]; then \
- make clean; \
- fi
- rm -f config.{log,cache,status} Makefile
- rm -f `find . -name "*~"`
- rm -rf debian/tmp debian/files* core debian/substvars
- binary-indep: checkroot build
- $(checkdir)
- # There are no architecture-independent files to be uploaded
- # generated by this package. If there were any they would be
- # made here.
- binary-arch: checkroot build
- $(checkdir)
- rm -rf debian/tmp
- install -d debian/tmp/usr/bin debian/tmp/etc debian/tmp/usr/man/man1 debian/tmp/usr/man/man5
- make install prefix=`pwd`/debian/tmp/usr INSTALL="/usr/bin/install -p" DESTDIR=`pwd`/debian/tmp
- ln patchlevel.h changelog.tmp
- ln LEGAL.NOTICE debian/copyright
- debstd changelog.tmp README
- rm -f changelog.tmp debian/copyright
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
- define checkdir
- test -f debian/rules
- endef
- # Below here is fairly generic really
- binary: binary-indep binary-arch
- source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
- checkroot:
- $(checkdir)
- test root = "`whoami`"
- .PHONY: binary binary-arch binary-indep clean checkroot
|