903-file-hurd.patch 512 B

123456789101112131415161718
  1. Author: Michael Casadevall <sonicmctails@gmail.com>
  2. Description: Fixes a FTBFS on hurd (Closes: #433716).
  3. diff -Naur file.orig/src/magic.c file/src/magic.c
  4. --- file.orig/src/magic.c 2007-03-26 17:59:50.000000000 +0000
  5. +++ file/src/magic.c 2007-07-19 06:25:16.000000000 +0000
  6. @@ -58,6 +58,11 @@
  7. #include <locale.h>
  8. #endif
  9. +#ifndef PIPE_BUF
  10. +// Get the PIPE_BUF from pathconf
  11. +#define PIPE_BUF pathconf(".", _PC_PIPE_BUF)
  12. +#endif
  13. +
  14. #include <netinet/in.h> /* for byte swapping */
  15. #include "patchlevel.h"