12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455 |
- #!/usr/bin/make -f
- package=file
- build:
- $(checkdir)
- make COPTS=-O2 all
- touch build
- clean:
- $(checkdir)
- -rm -f build
- make clean
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
- binary-indep: checkroot build
- $(checkdir)
- # There are no architecture-independent files to be uploaded
- # generated by this package. If there were any they would be
- # made here.
- binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp/usr/bin
- install -d debian/tmp/etc
- make install DESTDIR=`pwd`/debian/tmp
- ln patchlevel.h changelog
- ln LEGAL.NOTICE debian/copyright
- debstd changelog README
- rm changelog
- rm debian/copyright
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
- define checkdir
- test -f debian/rules
- endef
- # Below here is fairly generic really
- binary: binary-indep binary-arch
- source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
- checkroot:
- $(checkdir)
- test root = "`whoami`"
- .PHONY: binary binary-arch binary-indep clean checkroot
|