0010-mdadm.patch 882 B

12345678910111213141516171819202122232425262728293031
  1. Author: Russell Coker <russell@coker.com.au>
  2. Description: Adding new magics for Linux Software RAID (Closes: #663454).
  3. --- a/magic/Magdir/linux
  4. +++ b/magic/Magdir/linux
  5. @@ -416,3 +416,25 @@
  6. # glibc locale archive as defined in glibc locale/locarchive.h
  7. 0 lelong 0xde020109 locale archive
  8. >24 lelong x %d strings
  9. +
  10. +# Linux Software RAID (mdadm)
  11. +# Russell Coker <russell@coker.com.au>
  12. +4096 lelong 0xa92b4efc Linux Software RAID
  13. +>4100 lelong x version 1.2 (%d)
  14. +>4112 belong x UUID=%8x:
  15. +>4116 belong x \b%8x:
  16. +>4120 belong x \b%8x:
  17. +>4124 belong x \b%8x
  18. +>4128 string x name=%s
  19. +>4168 lelong x level=%d
  20. +>4188 lelong x disks=%d
  21. +
  22. +0 lelong 0xa92b4efc Linux Software RAID
  23. +>4 lelong x version 1.1 (%d)
  24. +>16 belong x UUID=%8x:
  25. +>20 belong x \b%8x:
  26. +>24 belong x \b%8x:
  27. +>28 belong x \b%8x
  28. +>32 string x name=%s
  29. +>72 lelong x level=%d
  30. +>92 lelong x disks=%d