12345678910111213141516171819202122232425 |
- Subject: Disable debug messages
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Date: 2022-12-20
- Forwarded: https://mailman.astron.com/pipermail/file/2022-December/001018.html
- --- a/src/softmagic.c
- +++ b/src/softmagic.c
- @@ -1461,7 +1461,7 @@
- // On purpose not INTMAX_MAX
- if (lhs >= UINT_MAX || lhs <= INT_MIN ||
- off >= UINT_MAX || off <= INT_MIN) {
- - fprintf(stderr, "lhs/off overflow %jd %jd\n", lhs, off);
- +/* fprintf(stderr, "lhs/off overflow %jd %jd\n", lhs, off); */
- return 1;
- }
-
- @@ -1497,7 +1497,7 @@
- if (m->in_op & FILE_OPINVERSE)
- offset = ~offset;
- if (offset >= UINT_MAX) {
- - fprintf(stderr, "offset overflow %jd\n", offset);
- +/* fprintf(stderr, "offset overflow %jd\n", offset); */
- return 1;
- }
- *rv = CAST(uint32_t, offset);
|