cherry-pick.FILE5_25-7-g1052fe4.drop-the-count-of-digits-allowed.patch 472 B

12345678910111213141516
  1. Subject: drop the count of digits allowed
  2. Origin: FILE5_25-7-g1052fe4
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Wed Sep 16 22:52:54 2015 +0000
  5. --- a/src/apprentice.c
  6. +++ b/src/apprentice.c
  7. @@ -2344,7 +2344,7 @@
  8. #define CHECKLEN() do { \
  9. for (len = cnt = 0; isdigit((unsigned char)*ptr); ptr++, cnt++) \
  10. len = len * 10 + (*ptr - '0'); \
  11. - if (cnt > 10 || len > 1024) \
  12. + if (cnt > 5 || len > 1024) \
  13. goto toolong; \
  14. } while (/*CONSTCOND*/0)