cherry-pick.FILE5_38-98-g028a1561.pr-93-undo-previous-there-are-dynamic-objects-shared-libraries-for-example.patch 928 B

12345678910111213141516171819202122232425262728
  1. Subject: PR/93: Undo previous: There are dynamic objects (shared libraries for example) (...)
  2. Origin: FILE5_38-98-g028a1561 <https://github.com/file/file/commit/FILE5_38-98-g028a1561>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Sun Apr 26 17:43:13 2020 +0000
  5. Bug-Debian: https://bugs.debian.org/948269
  6. PR/93: Undo previous: There are dynamic objects (shared libraries for example)
  7. that don't have interpeters and should not be counted as static. We
  8. need to figure out what to do with static-pie and gcc-9 separately.
  9. --- a/src/readelf.c
  10. +++ b/src/readelf.c
  11. @@ -1639,6 +1639,7 @@
  12. switch (xph_type) {
  13. case PT_DYNAMIC:
  14. doread = 1;
  15. + linking_style = "dynamically";
  16. break;
  17. case PT_NOTE:
  18. if (sh_num) /* Did this through section headers */
  19. @@ -1653,7 +1654,6 @@
  20. }
  21. /*FALLTHROUGH*/
  22. case PT_INTERP:
  23. - linking_style = "dynamically";
  24. doread = 1;
  25. break;
  26. default: