108-magic-remove-os2rexx.dpatch 890 B

123456789101112131415161718192021
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 108-magic-remove-os2rexx.dpatch by Kees Cook <kees@ubuntu.com>
  3. ##
  4. ## DP: Workaround regex DoS (CVE-2007-2026)
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/msdos file-4.20/magic/Magdir/msdos
  7. --- file-4.20.orig/magic/Magdir/msdos 2007-01-19 19:35:20.000000000 +0000
  8. +++ file-4.20/magic/Magdir/msdos 2007-05-17 16:44:41.000000000 +0000
  9. @@ -14,8 +14,8 @@
  10. # OS/2 batch files are REXX. the second regex is a bit generic, oh well
  11. # the matched commands seem to be common in REXX and uncommon elsewhere
  12. -100 regex/c =^\\s*call\\s+rxfuncadd.*sysloadfu OS/2 REXX batch file text
  13. -100 regex/c =^\\s*say\ ['"] OS/2 REXX batch file text
  14. +#100 regex/c =^\\s*call\\s+rxfuncadd.*sysloadfu OS/2 REXX batch file text
  15. +#100 regex/c =^\\s*say\ ['"] OS/2 REXX batch file text
  16. 0 leshort 0x14c MS Windows COFF Intel 80386 object file
  17. #>4 ledate x stamp %s