cherry-pick.FILE5_35-25-g48052fcf.fix-cut-n-pasto-for-regex-max-vsevolod-stakhov.patch 589 B

12345678910111213141516
  1. Subject: Fix cut-n-pasto for regex_max (Vsevolod Stakhov)
  2. Origin: FILE5_35-25-g48052fcf <https://github.com/file/file/commit/FILE5_35-25-g48052fcf>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Tue Dec 11 14:41:11 2018 +0000
  5. --- a/src/magic.c
  6. +++ b/src/magic.c
  7. @@ -604,7 +604,7 @@
  8. ms->elf_notes_max = (uint16_t)*(const size_t *)val;
  9. return 0;
  10. case MAGIC_PARAM_REGEX_MAX:
  11. - ms->elf_notes_max = (uint16_t)*(const size_t *)val;
  12. + ms->elf_regex_max = (uint16_t)*(const size_t *)val;
  13. return 0;
  14. case MAGIC_PARAM_BYTES_MAX:
  15. ms->bytes_max = *(const size_t *)val;