1673482234.FILE5_44-18-g9fa5e784.detect-android-art-baseline-profiles-found-in-apk-files.patch 1.4 KB

1234567891011121314151617181920212223242526272829303132
  1. Subject: Detect Android ART (baseline) profiles found in APK files. (FC Stegerman)
  2. Origin: FILE5_44-18-g9fa5e784 <https://github.com/file/file/commit/FILE5_44-18-g9fa5e784>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Thu Jan 12 00:10:34 2023 +0000
  5. --- a/magic/Magdir/android
  6. +++ b/magic/Magdir/android
  7. @@ -212,3 +212,24 @@
  8. 0 string/t .class\x20
  9. >&0 regex/512 \^\\.super\x20L.*;$ disassembled Android DEX Java class (smali/baksmali)
  10. !:ext smali
  11. +
  12. +# Android ART (baseline) profile + metadata: baseline.prof, baseline.profm
  13. +# Reference: https://android.googlesource.com/platform/frameworks/support/\
  14. +# +/refs/heads/androidx-main/profileinstaller/profileinstaller/\
  15. +# src/main/java/androidx/profileinstaller/ProfileTranscoder.java
  16. +# Reference: https://android.googlesource.com/platform/frameworks/support/\
  17. +# +/refs/heads/androidx-main/profileinstaller/profileinstaller/\
  18. +# src/main/java/androidx/profileinstaller/ProfileVersion.java
  19. +0 string pro\x00
  20. +>0 regex pro\x000[0-9][0-9]\x00 Android ART profile
  21. +!:ext prof
  22. +>>4 string 001\x00 \b, version 001 N
  23. +>>4 string 005\x00 \b, version 005 O
  24. +>>4 string 009\x00 \b, version 009 O MR1
  25. +>>4 string 010\x00 \b, version 010 P
  26. +>>4 string 015\x00 \b, version 015 S
  27. +0 string prm\x00
  28. +>0 regex prm\x000[0-9][0-9]\x00 Android ART profile metadata
  29. +!:ext profm
  30. +>>4 string 001\x00 \b, version 001 N
  31. +>>4 string 002\x00 \b, version 002